unidad de red mapeada desaparece

Todo sobre los distintos SSOO de Windows

Moderador: Moderadores

unidad de red mapeada desaparece

Notapor vlan7 » Mar Jun 19, 2007 1:13 pm

Hola.

Tengo problemas con unos clientes que usan Windows XP.

Tienen mapeada una unidad Z: a un recurso de red. El mapeo es persistente, al iniciar el sistema se le mapea la unidad Z: automaticamente.

El problema es que al cabo de un tiempo de inactividad, la unidad mapeada desaparece.

He buscado por google y he encontrado que ha habido gente con el mismo problema, pero no he encontrado solucion.

¿Alguna idea?

Gracias y un saludo.
There is a crack, a crack in everything That's how the light gets in. -subculture

zen7.vlan7.org
Avatar de Usuario
vlan7
<|:-D
<|:-D
 
Mensajes: 1176
Registrado: Dom Mar 05, 2006 11:16 pm
Ubicación: Mas alla del EIP

Notapor Bebbop » Mié Jun 20, 2007 10:38 am

Desaparece o se desconecta?

Eso entra dentro de lo normal... cuando mapeas una unidad y pasa un tiempo de inactividad la unidad se desconecta.

Si haces un net config server veras que pone "Tiempo de inactividad de sesión (min.)" y un numero... este es el tiempo que tiene que pasar de inactividad para que se desactive.

Aqui tienes mas info:
http://www.microsoft.com/technet/prodte ... x?mfr=true
Avatar de Usuario
Bebbop
Gran Wadalbertita
Gran Wadalbertita
 
Mensajes: 3424
Registrado: Mié Dic 14, 2005 2:46 pm
Ubicación: El Inframundo

Notapor vlan7 » Mié Jun 20, 2007 6:23 pm

Si, eso ya lo sabia. Se que es normal lo que describo a continuacion (que te aparezca un aspa roja):

Si un equipo mapea una unidad de red a un recurso compartido que reside en un servidor NT 4, Win2k o Win2k3 Server, la unidad mapeada puede ser desconectada tras un intervalo de inactividad, por defecto de 15 minutos, y el Explorador de Windows puede mostrar una "X" roja en el icono de la unidad mapeada. Sin embargo, si se intenta consultar o explorar la unidad asignada, se vuelve a conectar rápidamente.

Podemos configurar este comportamiento ejecutando el siguiente comando en el servidor:

net config server /autodisconnect:num

donde num es el numero de minutos que el servidor esperara antes de desconectar una unidad de red mapeada, con un valor maximo de 65.535.

Para desactivar la caracteristica de desconexion automática:

net config server /autodisconnect:-1

Todo eso segun documentacion oficial de Microsoft.

A lo que no encuentro explicacion es a que la unidad de red mapeada simplemente desaparece, que es lo que ocurre. Y los clientes tienen que cerrar sesion e iniciarla de nuevo para que les vuelva a aparecer. Y no me pasa con todos los clientes, solo con unos pocos.

Un saludo.
There is a crack, a crack in everything That's how the light gets in. -subculture

zen7.vlan7.org
Avatar de Usuario
vlan7
<|:-D
<|:-D
 
Mensajes: 1176
Registrado: Dom Mar 05, 2006 11:16 pm
Ubicación: Mas alla del EIP

Notapor Bebbop » Jue Jun 21, 2007 11:43 am

Con que lo hace? con un net use o con agregar unidad de red?
Avatar de Usuario
Bebbop
Gran Wadalbertita
Gran Wadalbertita
 
Mensajes: 3424
Registrado: Mié Dic 14, 2005 2:46 pm
Ubicación: El Inframundo

Notapor vlan7 » Vie Jun 22, 2007 10:52 am

Esta mapeada con boton derecho Mi PC / conectar unidad de red. Aunque eso no deja de ser un net use por debajo.

Saludos.
There is a crack, a crack in everything That's how the light gets in. -subculture

zen7.vlan7.org
Avatar de Usuario
vlan7
<|:-D
<|:-D
 
Mensajes: 1176
Registrado: Dom Mar 05, 2006 11:16 pm
Ubicación: Mas alla del EIP

Notapor okahei » Vie Jun 22, 2007 10:53 am

risperdal escribió:Esta mapeada con boton derecho Mi PC / conectar unidad de red. Aunque eso no deja de ser un net use por debajo.

Saludos.


No sabría qué decirte, pero eso mismo me ha pasado a mí alguna vez.

Si lo haces en un script de inicio a mí no me ha fallado nunca.

un saludo.
-<|:·)
Avatar de Usuario
okahei
-<|:·þ
-<|:·þ
 
Mensajes: 3715
Registrado: Sab Ene 29, 2005 12:12 pm

Notapor Bebbop » Vie Jun 22, 2007 12:34 pm

Si es un controlador de dominio añadelo en el inicio de sesion
Avatar de Usuario
Bebbop
Gran Wadalbertita
Gran Wadalbertita
 
Mensajes: 3424
Registrado: Mié Dic 14, 2005 2:46 pm
Ubicación: El Inframundo

Notapor vlan7 » Lun Jun 25, 2007 9:02 am

No es un CD Bebbop, es un simple servidor de archivos Windows Server 2003.

He encontrado una solución parcial: crear un script .vbs que obtiene una lista de todas las unidades mapeadas, las desconecta y las reconecta de nuevo. El script es el siguiente:

Código: Seleccionar todo
Set WshNetwork = WScript.CreateObject("WScript.Network")
Set oDrives = WshNetwork.EnumNetworkDrives
For i = 0 to oDrives.Count - 1 Step 2
WshNetwork.RemoveNetworkDrive oDrives.Item(i), TRUE
WshNetwork.MapNetworkDrive oDrives.Item(i), oDrives.Item(i+1)
Next


La fuente es http://www.hillock.excepts.computing.net/networking/wwwboard/forum/21105.html , que yo en programacion estoy flojo.

Si esto no me funciona le dire al jefe de pillar espacio de la cabina de discos en RAID para el servidor de archivos que tenemos en un linux con Samba, que esta casi al limite de espacio. Como dice un compañero mio, "no vaya a ser el diablo..." y con Samba funcione a la perfeccion.

¿A que te refieres con un script de inicio okahei? ¿A meter en el inicio un net use del directorio deseado con la opcion /persistent?

Un saludo y gracias por vuestras respuestas.
There is a crack, a crack in everything That's how the light gets in. -subculture

zen7.vlan7.org
Avatar de Usuario
vlan7
<|:-D
<|:-D
 
Mensajes: 1176
Registrado: Dom Mar 05, 2006 11:16 pm
Ubicación: Mas alla del EIP

Notapor okahei » Lun Jun 25, 2007 9:18 am

Hola

Me refiero a un Logon script.

un saludo.
-<|:·)
Avatar de Usuario
okahei
-<|:·þ
-<|:·þ
 
Mensajes: 3715
Registrado: Sab Ene 29, 2005 12:12 pm

Notapor Yorkshire » Lun Jun 25, 2007 11:15 am

Código: Seleccionar todo
\\nombre_del_dominio\netlogon

Ahí creas un cmd (ó BAT para los nostágicos) con el/los NET USE y se lo asignas al/los user(s) en su perfil, en la "Secuencia de comandos de inicio de sesión".

Salu2
Linux registered user #346840
Avatar de Usuario
Yorkshire
Gran Wadalbertita
Gran Wadalbertita
 
Mensajes: 4488
Registrado: Mié Ene 26, 2005 5:05 pm
Ubicación: -<|:-P[G]


Volver a Windows

¿Quién está conectado?

Usuarios navegando por este Foro: Bing [Bot] y 1 invitado

cron