Targeta ethernet muy vacilona xD

Todo lo que tengas que decir sobre Gnu/Linux y SSOO alternativos.

Moderador: Moderadores

Targeta ethernet muy vacilona xD

Notapor securedigital » Mié Jul 23, 2008 3:00 pm

Hola a todos!!

Cuanto tiempo que no escribo ningun post...he estado tan tan ocupado ...madre mia, en fin.

Tengo aqui un problemilla.
Tengo una maquina, con una targeta ethernet. La conexion/direcciones es asignada por DHCP, pero slackware no lo esta reconociendo, me refiero que no es capaç de coger nada.
Si ,he probado el daemon cliente de dhcp manualmente sobre eth0 :)
Tambien he puesto las direcciones manualmente, y nada.

"destination unreachable"

Default sin tocar nada:

Código: Seleccionar todo
eth0      Link encap:Ethernet  HWaddr 00:1F:C6:0B:A3:8B
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:981 errors:0 dropped:2384486980 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:97103 (94.8 KiB)  TX bytes:0 (0.0 b)
          Interrupt:17 Base address:0x4000


Colocando los valores manualmente (tambien el GW, route add default gw ip)

Código: Seleccionar todo
eth0      Link encap:Ethernet  HWaddr 00:1F:C6:0B:A3:8B
          inet addr:161.116.156.70  Bcast:161.116.156.255  Mask:255.255.255.0
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:2002 errors:0 dropped:2283560793 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:193596 (189.0 KiB)  TX bytes:0 (0.0 b)
          Interrupt:17 Base address:0x4000


No se me olvido el resolv.conf, el cual le puse tambien manualmente los dns internos.

Un desespero, pues no se que hacer ya mas con este problema y es que sin red.. ..
Si alguien tiene alguna idea...se agradece, de todas formas adjunto informacion extra (logs, modulos cargados, etc)

Logs arranque sistema (dmesg)
r8169 Gigabit Ethernet driver 2.2LK loaded
...
eth0: RTL8168b/8111b at 0xf94b4000, 00:1f:c6:0b:a3:8b, IRQ 17
...
r8169: eth0: link down
...
r8169: eth0: link down
r8169: eth0: link down

listado pci (lspci)
02:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 02

lkm cargados/modulos
driver loaded in kernel r8169 -- 29704 0


PD: el esto de la targeta se pone como antes visto al log en down, evidentemente tambien la puse en "up" :)

Gracias
The man who whispered to the computers

FAD58DE7366495DB4650CFEFAC2FCD61
Avatar de Usuario
securedigital
:-D
:-D
 
Mensajes: 111
Registrado: Sab Nov 25, 2006 3:26 pm
Ubicación: Dentro de un AS/400. xD

Notapor okahei » Mié Jul 23, 2008 3:37 pm

mii-tool te detecta la tarjeta ?

y ethtool ?

si le pasas un test a la tarjeta ethtool -t eth0 qué te dice ?

un saludo.
-<|:·)
Avatar de Usuario
okahei
-<|:·þ
-<|:·þ
 
Mensajes: 3715
Registrado: Sab Ene 29, 2005 12:12 pm

Notapor securedigital » Mié Jul 23, 2008 4:00 pm

ethtool -t eth0
Cannot test: Operation not supported

mii-tool eth0
SIOCGMIIPHY on 'eth0' failed: Operation not supported


:badgrin:
The man who whispered to the computers

FAD58DE7366495DB4650CFEFAC2FCD61
Avatar de Usuario
securedigital
:-D
:-D
 
Mensajes: 111
Registrado: Sab Nov 25, 2006 3:26 pm
Ubicación: Dentro de un AS/400. xD

Notapor okahei » Mié Jul 23, 2008 4:13 pm

bájate el driver más moderno lo instalas y a ver qué pasa

un saludo.
-<|:·)
Avatar de Usuario
okahei
-<|:·þ
-<|:·þ
 
Mensajes: 3715
Registrado: Sab Ene 29, 2005 12:12 pm

Notapor securedigital » Mié Jul 23, 2008 4:20 pm

:) ya hize eso tambien, lo que pasa es que por lo que acabo de ver aun hay otra version que salio mas recientemente.
yo instale r8168-8.003.00.tar.bz2, y ni compilaba xD

voy a probar con r8168-8.006.00_.tar.bz2 haver si tira. En breve lo comento.

Salu2
The man who whispered to the computers

FAD58DE7366495DB4650CFEFAC2FCD61
Avatar de Usuario
securedigital
:-D
:-D
 
Mensajes: 111
Registrado: Sab Nov 25, 2006 3:26 pm
Ubicación: Dentro de un AS/400. xD

Notapor securedigital » Mié Jul 23, 2008 4:43 pm

Me da el mismo error que cuando compile ese driver viejo


Código: Seleccionar todo
make clean modules
make -C src/ clean
make[1]: Entering directory `/root/Desktop/r8168-8.006.00/src'
rm -rf *.o *.ko *~ core* .dep* .*.d .*.cmd *.mod.c *.a *.s .*.flags .tmp_versions Module.symvers Modules.symvers rset
make[1]: Leaving directory `/root/Desktop/r8168-8.006.00/src'
make -C src/ modules
make[1]: Entering directory `/root/Desktop/r8168-8.006.00/src'
make -C /lib/modules/2.6.21.5/build SUBDIRS=/root/Desktop/r8168-8.006.00/src modules
make: Entering an unknown directory
make: *** /lib/modules/2.6.21.5/build: No such file or directory.  Stop.
make: Leaving an unknown directory
make[1]: *** [modules] Error 2
make[1]: Leaving directory `/root/Desktop/r8168-8.006.00/src'
make: *** [modules] Error 2




Código: Seleccionar todo
os r8168-8.006.00 # make install
make -C src/ install
make[1]: Entering directory `/root/Desktop/r8168-8.006.00/src'
install -m 744 -c r8168.ko /lib/modules/2.6.21.5/kernel/drivers/net/
install: cannot stat `r8168.ko': No such file or directory
make[1]: *** [install] Error 1
make[1]: Leaving directory `/root/Desktop/r8168-8.006.00/src'
make: *** [install] Error 2

The man who whispered to the computers

FAD58DE7366495DB4650CFEFAC2FCD61
Avatar de Usuario
securedigital
:-D
:-D
 
Mensajes: 111
Registrado: Sab Nov 25, 2006 3:26 pm
Ubicación: Dentro de un AS/400. xD


Volver a Gnu/Linux y SSOO alternativos

¿Quién está conectado?

Usuarios navegando por este Foro: No hay usuarios registrados visitando el Foro y 4 invitados

cron